Back to overview
Degraded

Twilio/AWS down

Oct 20 at 09:00am CDT
Affected services
Ease Communications Center

Resolved
Oct 20 at 05:01pm CDT

The AWS outage has been resolved

Created
Oct 20 at 09:00am CDT

AWS is experiencing intermittent issue which has resulted in service degradation by twilio, leading to issues such as failing to connect to SMS conversations and making outbound phone calls.