Back to overview
Degraded

StorEdge downtime

Aug 26, 2025 at 07:30pm UTC
Affected services
Ease Communications Center
Ease Web Assistant
StorEdge

Resolved
Aug 26, 2025 at 11:04pm UTC

Backfill completed. Monitoring to make sure issue is resolved.

Updated
Aug 26, 2025 at 10:46pm UTC

StorEdge seems to have recovered. Backfilling previously missed automation.

Updated
Aug 26, 2025 at 09:40pm UTC

Still in communications with StorEdge support.

Updated
Aug 26, 2025 at 08:32pm UTC

Confirmed that the StorEdge issue is limited to only reservation syncing and therefore affects automated lead follow-ups including creation of lead follow-up tasks in Comms Center. Comms Center overall is functional however.

Created
Aug 26, 2025 at 07:30pm UTC

We are currently managing an intermittent StorEdge integration issue. Tenant, lead, and reservation syncing may be affected.